Page 1 of 2 12 LastLast
Results 1 to 25 of 39

Thread: 05 Hemi Ram question

  1. #1
    Join Date
    May 2007
    Location
    Clarksburg, West Virginia, United States
    Posts
    8,635

    Default 05 Hemi Ram question

    Ok i have a question for you dodge guys. Its a stupud issue but it has me stumped. We have a 2005 ram 2500 with the hemi. It has 276000 miles and get used well. It is our business truck and pulls my back hoe, escavator, and what ever material i need. Anyway point is the truck gets worked hard. The ptoblem i have is that under acceleration it wants to sputter and cut out. There is no codes or check engine lights. The plugs are fairly new. Please help!

    Sent from my SPH-L720T using Tapatalk

  2. #2
    Join Date
    Feb 2012
    Location
    WV
    Posts
    45

    Default Re: 05 Hemi Ram question

    I see that a lot I would first check the throttle body. In the winter months they get a lot of carbon build up and until it shuts completely you can notice some hesitation or missing with no codes. It really could be so many things.

    - - - Updated - - -

    Did you pull the plugs? And check them for oil.
    Quote Originally Posted by Dina
    "Wanna be in my video? We're doing a documentary....on dumbasses."

  3. #3
    Join Date
    May 2007
    Location
    Clarksburg, West Virginia, United States
    Posts
    8,635

    Default Re: 05 Hemi Ram question

    Yea we replaced the plugs recently and they were perfectly colored with no oil

    Sent from my SPH-L720T using Tapatalk

  4. #4
    Join Date
    Dec 1969
    Location
    Toolshed
    Posts
    14,149

    Default Re: 05 Hemi Ram question

    It sit all winter? could be bad fuel..

  5. #5
    Join Date
    May 2007
    Location
    Clarksburg, West Virginia, United States
    Posts
    8,635

    Default Re: 05 Hemi Ram question

    No we use it daily. Hasnt set any of its life

    Sent from my SPH-L720T using Tapatalk

  6. #6
    Join Date
    Feb 2012
    Location
    WV
    Posts
    45

    Default Re: 05 Hemi Ram question

    I know they add a lot of crap to fuel to keep it from freezing have you put any dry gas in?
    Quote Originally Posted by Dina
    "Wanna be in my video? We're doing a documentary....on dumbasses."

  7. #7
    Join Date
    May 2007
    Location
    Clarksburg, West Virginia, United States
    Posts
    8,635

    Default Re: 05 Hemi Ram question

    No i havent tried dry gas. I did do fuel injector cleaner. My old crown vic did the same thing every so often and the injector cleaner cleared it up. Didnt work on this though

    Sent from my SPH-L720T using Tapatalk

  8. #8
    Join Date
    Sep 2013
    Location
    Cowen WV
    Posts
    235

    Default Re: 05 Hemi Ram question

    Do you have access to a scanner that reads live data? If you do watch the front O2 sensors when its acting up. If the voltage drops to nearly zero on both front O2 sensors then you might be losing fuel pressure. If the voltage goes up and stays there you might have a plugged cat convertor. Normally you will get several codes when they act up badly. Does the fuel gauge work? Some fault codes like misfire codes are disabled when the gas tank reads less than a quarter. A good scanner like snap ons will show which cylinder is misfiring while you are driving. Also we have had a few high mileage hemis break a coil off a valve spring. At low engine speeds they run fine but under higher rpm that valve floats and if its an intake valve spring it causes misfires on random cylinders because of exhaust entering the intake.

  9. #9
    Join Date
    May 2007
    Location
    Clarksburg, West Virginia, United States
    Posts
    8,635

    Default Re: 05 Hemi Ram question

    No i dont have access to a live scanner, i wish i did. The only scanner i have is the bullydog programmer. The fuel gauge does work and as far a fuel preasure it SHOULD be fine. We just replaced the fuel pump. It did the same thing before the pump. It dont really seem like a misfire. Ill have to try to get a video.

    Sent from my SPH-L720T using Tapatalk

  10. #10
    Join Date
    May 2007
    Location
    Clarksburg, West Virginia, United States
    Posts
    8,635

    Default Re: 05 Hemi Ram question

    Its really random too. It dont happen every time

    Sent from my SPH-L720T using Tapatalk

  11. #11
    Join Date
    May 2007
    Location
    Clarksburg, West Virginia, United States
    Posts
    8,635

    Default Re: 05 Hemi Ram question

    I tried for a freaking hour to get a video but the camera just wont grab the sound. It dont always do it at the upper rpm. It seems worse when the truck goes into high gear and you start up a hill loading the engine

    Sent from my SPH-L720T using Tapatalk

  12. #12
    Join Date
    Sep 2013
    Location
    Cowen WV
    Posts
    235

    Default Re: 05 Hemi Ram question

    That sounds like an ignition problem. Maybe you have a weak coil. Hard to find out which one if it doesn't set a code though.

  13. #13
    Join Date
    May 2007
    Location
    Clarksburg, West Virginia, United States
    Posts
    8,635

    Default Re: 05 Hemi Ram question

    Wouldnt a weak coil set a code?

    Sent from my SPH-L720T using Tapatalk

  14. #14
    Join Date
    Sep 2013
    Location
    Cowen WV
    Posts
    235

    Default Re: 05 Hemi Ram question

    Only if its winding is open circuit or dead shorted internally. If it has an internal high voltage leak or just cant produce the 30,000 plus volts it needs to fire the plug under load then they usually don't set a coil failure code. You might mist some water on each coil and plug wire one at a time and drive it to see if the problem gets worse. If it does then that might lead you to which one needs replacing. Access to a good scanner though would save you a lot of time. Watch the misfire counter and drive it and if it is indeed an engine miss it will show up. The misfire counter on most engines is several times more sensitive than what it takes to set a hard code. So even if no codes set you can still see which cylinder is dropping out.

  15. #15
    Join Date
    May 2007
    Location
    Clarksburg, West Virginia, United States
    Posts
    8,635

    Default Re: 05 Hemi Ram question

    Ugh i was afraid you would say that. Ok scanner searching it is then

    Sent from my SPH-L720T using Tapatalk

  16. #16
    Join Date
    Sep 2013
    Location
    Cowen WV
    Posts
    235

    Default Re: 05 Hemi Ram question

    I'm all set up for diagnostics if you can stand the drive down to Craigsville some day. And no charge for a WVStreets member too lol!

  17. #17
    Join Date
    Aug 2005
    Location
    Clarksburg, Wv
    Posts
    4,986

    Default Re: 05 Hemi Ram question

    Josh has a scanner.
    09 Sonata (My DD)
    92 C1500 ( Winter Beater/ Hauler)


    07accord - "I want to be a nittany lion!"
    "I'm pretty sure I have no fam. in South Jersey.Real mullet fairing people don't have spray tans." Levilz


  18. #18
    Join Date
    May 2007
    Location
    Clarksburg, West Virginia, United States
    Posts
    8,635

    Default Re: 05 Hemi Ram question

    I dont want to wait 15 month to get it done

    Sent from my SPH-L720T using Tapatalk

  19. #19
    Join Date
    Aug 2009
    Location
    Sutton
    Posts
    6,610

    Default Re: 05 Hemi Ram question

    You said you changed the plugs but did you change the wires and boots? Plugs in these trucks are a recommended change every 30,000 miles. Boots are rarely ever changed just cause they're overlooked.

    Sig by RogerStout

    www.bullplayztrading.com

    2004 SRT 10 Red RC Skanky~Hott Car Club President
    #2402 out of 3057, Built 6/4/2004
    Dyno####433/469 at the wheels!!!
    Mopar Nationals 2010 Viper Truck Show Winner
    Mopar Nationals 2011 Viper Truck Show 2nd Place
    Mopar Nationals 2012 No Show
    Mopar Nationals 2013 Viper Truck Show Winner

  20. #20
    Join Date
    May 2007
    Location
    Clarksburg, West Virginia, United States
    Posts
    8,635

    Default Re: 05 Hemi Ram question

    The plugs had about 250k on them but no we didnt do the boots. Its in the plans this week but i didnt figure they would ha e anything to do with this behavior

    Sent from my SPH-L720T using Tapatalk

  21. #21
    Join Date
    Aug 2009
    Location
    Sutton
    Posts
    6,610

    Default Re: 05 Hemi Ram question

    Change the boots and the wires before you try anything else.

    Sig by RogerStout

    www.bullplayztrading.com

    2004 SRT 10 Red RC Skanky~Hott Car Club President
    #2402 out of 3057, Built 6/4/2004
    Dyno####433/469 at the wheels!!!
    Mopar Nationals 2010 Viper Truck Show Winner
    Mopar Nationals 2011 Viper Truck Show 2nd Place
    Mopar Nationals 2012 No Show
    Mopar Nationals 2013 Viper Truck Show Winner

  22. #22
    Join Date
    May 2007
    Location
    Clarksburg, West Virginia, United States
    Posts
    8,635

    Default Re: 05 Hemi Ram question

    Ok cool

    Sent from my SPH-L720T using Tapatalk

  23. #23
    Join Date
    Jul 2008
    Location
    WV
    Posts
    13,951

    Default Re: 05 Hemi Ram question

    Cheapest things first how many miles on the 02 sensors they probably should be looked at also. I like to use marvel mystery oil has all but fixed problems with my jeep. Check throttle body too I will bet it has a lot of build up. Also with it on a scanner it may not throw a light but may throw a code. Is your Maf clean? Filter new/ clean.... That's a loooot of miles lol
    2001 Corvette - Heads, Cam, Intake, Full exhaust, Hotchkiss Swaybars, z06 brake ducts, SS brake pistons & Lines Etc. Lowered & Murdered out.
    2000 Trans AM WS6 - Forged Motor APS Twin Turbo Kit. Full Suspension & C5 brakes.... in pieces currently
    1998 Trans AM STS Turbo
    1997 Jeep Cherokee - when you just gotta go places other things won't take you.
    1995 Mercury Grand Marquis - ugly but comfortable

  24. #24
    Join Date
    May 2007
    Location
    Clarksburg, West Virginia, United States
    Posts
    8,635

    Default Re: 05 Hemi Ram question

    Ill see whay all is dirty tomorrow. O2's are factory as far as i know

    Sent from my SPH-L720T using Tapatalk

  25. #25
    Join Date
    Mar 2008
    Location
    Clarksburg, WV
    Posts
    10,366

    Default Re: 05 Hemi Ram question

    Those o2's need changed man. Take care of that and the boots, and I bet it will make a big difference.

    Sent from my SCH-R830 using Tapatalk



    03' SSS, 98' T/A,84' Monte Carlo SS,08' Civic, 65' Malibu SS
    RNA Team #217
    Rally Appalachia 11': 7th, Day 3
    Rally Dixie 12': Top 20, Day 1; Top 10, Day 2; Fastest Time, Day 3. (But DQ for ticket)
    Penn Dutch Rally 14': Turtle Award!
    Mille Rally 14':We finished
    Penn Dutch Rally 15': 2ND OVERALL!


    www.elzaperformance.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •